Beats 1 radio – No go on older versions of OSX below 10.9.3

Beats 1 Radio OSX 10.9.3 restriction warning
Beats 1 Radio OSX 10.9.3 restriction warning
Beats 1 Radio OSX 10.9.3 restriction warning

I’m really disappointed that Beats 1 Radio won’t work in iTunes on older versions of OSX. On my mountain lion OSX 10.8.5 machine which is an older iMac (and runs awful on Yosemite) I found that when updating to iTunes 12.2 all parts of Apple Music work with the exception of Beats 1 radio. This seems ridiculous as everything else works fine. It’s obviously a ploy to get everyone to upgrade to Yosemite & eventually El Capitan. Problem is, older machines don’t play well with the latest OSX. Read More....

ios 8.4 apple music and beats 1 radio is a go