Fix Blank Cloudflare Settings in Wordpress

WordPress Cloudflare 3.0.3 plugin blank settings page – fixed

I’ve been having a nightmare trying to get the Cloudflare plugin for wordpress to play nicely. After installing it I found that I had a blank settings page when I tried to enter my API details. I tried setting Cloudflare into development mode & also pausing Cloudflare but still the settings page wouldn’t load.

I started searching online for a solution and there seemed to be solutions for loads of older versions, but nothing about the current 3.0.3 plugin. After successfully getting the plugin to run on various other copies of wordpress on the same server I started to look at the config of the problematic blog. The only thing that differs on this site, compared to my others, is the level of security I have set. I quickly discovered that the All In One security plugin (also known as WP security) was stopping the Cloudflare settings page from loading. Simply disabling the WP All In One Security plugin allowed me to load the cloudflare wordpress plugin and get around the blank grey settings screen.

I can now configure wordpress without any issues to use Cloudflare. Once I set all of the API settings in the cloudflare plugin I reactivated the WP All In One security plugin and had it reinsert all of my .htaccess rules. surprisingly, the Cloudlfare plugin now plays nicely with the WP All In One Security plugin and I can get on with my day.

If you are having issues with a blank settings page using the cloudflare plugin with wordpress, have a look at your security plugins & disable one at a time until you are able to enter your API credentials. Then re-enable and hopefully you can carry on with your blogging.

Hope this works for you. Please do let me know if it does.

John Large

John Large - Uber Techie!

Leave a Reply